ECom2

Build: #197 failed Changes by MageParts Office <info@mageparts.com>

Build result summary

Details

Completed
Duration
1 minute
Labels
None
Agent
Agent 15
Revision
25156f44da54759889a165a27812cc64667f2b50 25156f44da54759889a165a27812cc64667f2b50
Failing since
#162 (Scheduled – )
Fixed in
#248 (Manual run by Tomas Tornevall)
No failed test found. A possible compilation error occurred.

Responsible

This build has been failing since #162
No one has taken responsibility

Code commits

Author Commit Message Commit date
MageParts Office <info@mageparts.com> MageParts Office <info@mageparts.com> 25156f44da54759889a165a27812cc64667f2b50 25156f44da54759889a165a27812cc64667f2b50 Merged in ECP-146 (pull request #95)
ECP-146

Approved-by: Thomas Tornevall
Approved-by: Mikael Jacobson
Approved-by: Gert Larsson
MageParts Office <info@mageparts.com> MageParts Office <info@mageparts.com> 53a0d3ea35d2d87ad3a8fe1b18bdadbb5cc65624 53a0d3ea35d2d87ad3a8fe1b18bdadbb5cc65624 Merged in ECP-143 (pull request #93)
ECP-143

Approved-by: Mikael Jacobson
Approved-by: Gert Larsson
Peter Sjöqvist <info@mageparts.com> Peter Sjöqvist <info@mageparts.com> ca1b4392fe5a10332d23c7bd52c0e41cf6e27f41 m ca1b4392fe5a10332d23c7bd52c0e41cf6e27f41 ECP-146
Correct Payment property validation.

* Added CountryCode enum to property.
Peter Sjöqvist <info@mageparts.com> Peter Sjöqvist <info@mageparts.com> 9da3df913a65b2ffac59672527494e9a042d8a79 m 9da3df913a65b2ffac59672527494e9a042d8a79 Merge branch 'master' into ECP-146
Peter Sjöqvist <info@mageparts.com> Peter Sjöqvist <info@mageparts.com> c93b6c4298366896298f69f0111bc8f11792d70c m c93b6c4298366896298f69f0111bc8f11792d70c ECP-143
Correct Metadata property validation.

* Made `creator` required as per the docs.

Configuration changes

Plan configuration has changed since the last successful build. See the plan audit log for more details.

Jira issues

IssueDescriptionStatus
Unknown Issue TypeECP-143Could not obtain issue details from Jira
Unknown Issue TypeECP-146Could not obtain issue details from Jira

Error summary for Test Ecom2

The job generated some errors, drill down into the full build log for more details.

  - Locking webmozart/path-util (2.3.0)
Writing lock file
Installing dependencies from lock file (including require-dev)
Package operations: 75 installs, 0 updates, 0 removals
    0 [>---------------------------]    0 [>---------------------------]
  - Installing composer/package-versions-deprecated (1.11.99.5): Extracting archive
  - Installing composer/pcre (3.0.0): Extracting archive
  - Installing doctrine/lexer (1.2.3): Extracting archive
  - Installing psr/container (2.0.2): Extracting archive
  - Installing symfony/service-contracts (v3.1.1): Extracting archive
  - Installing symfony/stopwatch (v6.1.0): Extracting archive
  - Installing symfony/process (v6.1.3): Extracting archive
  - Installing symfony/polyfill-php81 (v1.26.0): Extracting archive
  - Installing symfony/polyfill-php80 (v1.26.0): Extracting archive
  - Installing symfony/polyfill-mbstring (v1.26.0): Extracting archive
  - Installing symfony/deprecation-contracts (v3.1.1): Extracting archive
  - Installing symfony/options-resolver (v6.1.0): Extracting archive
  - Installing symfony/finder (v6.1.3): Extracting archive
  - Installing symfony/polyfill-ctype (v1.26.0): Extracting archive
  - Installing symfony/filesystem (v6.1.4): Extracting archive
  - Installing psr/event-dispatcher (1.0.0): Extracting archive
  - Installing symfony/event-dispatcher-contracts (v3.1.1): Extracting archive
  - Installing symfony/event-dispatcher (v6.1.0): Extracting archive
  - Installing symfony/polyfill-intl-normalizer (v1.26.0): Extracting archive
  - Installing symfony/polyfill-intl-grapheme (v1.26.0): Extracting archive
  - Installing symfony/string (v6.1.4): Extracting archive
  - Installing symfony/console (v6.1.4): Extracting archive
  - Installing sebastian/diff (4.0.4): Extracting archive
  - Installing psr/cache (3.0.0): Extracting archive
  - Installing doctrine/annotations (1.13.3): Extracting archive
  - Installing psr/log (3.0.0): Extracting archive
  - Installing composer/xdebug-handler (3.0.3): Extracting archive
  - Installing composer/semver (3.3.2): Extracting archive
  - Installing friendsofphp/php-cs-fixer (v3.11.0): Extracting archive
  - Installing webmozart/assert (1.11.0): Extracting archive
  - Installing phpdocumentor/reflection-common (2.2.0): Extracting archive
  - Installing phpdocumentor/type-resolver (1.6.1): Extracting archive
  - Installing phpdocumentor/reflection-docblock (5.3.0): Extracting archive
  - Installing symfony/dependency-injection (v6.1.3): Extracting archive
  - Installing symfony/config (v6.1.3): Extracting archive
  - Installing pdepend/pdepend (2.12.1): Extracting archive
  - Installing phpmd/phpmd (2.13.0): Extracting archive
  - Installing phpstan/phpstan (1.8.6): Extracting archive
  - Installing sebastian/version (3.0.2): Extracting archive
  - Installing sebastian/type (3.2.0): Extracting archive
  - Installing sebastian/resource-operations (3.0.3): Extracting archive
  - Installing sebastian/recursion-context (4.0.4): Extracting archive
  - Installing sebastian/object-reflector (2.0.4): Extracting archive
  - Installing sebastian/object-enumerator (4.0.4): Extracting archive
  - Installing sebastian/global-state (5.0.5): Extracting archive
  - Installing sebastian/exporter (4.0.5): Extracting archive
  - Installing sebastian/environment (5.1.4): Extracting archive
  - Installing sebastian/comparator (4.0.8): Extracting archive
  - Installing sebastian/code-unit (1.0.8): Extracting archive
  - Installing sebastian/cli-parser (1.0.1): Extracting archive
  - Installing phpunit/php-timer (5.0.3): Extracting archive
  - Installing phpunit/php-text-template (2.0.4): Extracting archive
  - Installing phpunit/php-invoker (3.1.1): Extracting archive
  - Installing phpunit/php-file-iterator (3.0.6): Extracting archive
  - Installing theseer/tokenizer (1.2.1): Extracting archive
  - Installing nikic/php-parser (v4.15.1): Extracting archive
  - Installing sebastian/lines-of-code (1.0.3): Extracting archive
  - Installing sebastian/complexity (2.0.2): Extracting archive
  - Installing sebastian/code-unit-reverse-lookup (2.0.3): Extracting archive
  - Installing phpunit/php-code-coverage (9.2.17): Extracting archive
  - Installing phar-io/version (3.2.1): Extracting archive
  - Installing phar-io/manifest (2.0.3): Extracting archive
  - Installing myclabs/deep-copy (1.11.0): Extracting archive
  - Installing doctrine/instantiator (1.4.1): Extracting archive
  - Installing phpunit/phpunit (9.5.25): Extracting archive
  - Installing squizlabs/php_codesniffer (3.7.1): Extracting archive
  - Installing webmozart/path-util (2.3.0): Extracting archive
  - Installing openlss/lib-array2xml (1.0.0): Extracting archive
  - Installing netresearch/jsonmapper (v4.0.0): Extracting archive
  - Installing felixfbecker/language-server-protocol (v1.5.2): Extracting archive
  - Installing felixfbecker/advanced-json-rpc (v3.2.1): Extracting archive
  - Installing dnoegel/php-xdg-base-dir (v0.1.1): Extracting archive
  - Installing amphp/amp (v2.6.2): Extracting archive
  - Installing amphp/byte-stream (v1.8.1): Extracting archive
  - Installing vimeo/psalm (4.27.0): Extracting archive
  0/74 [>---------------------------]   0%
10/74 [===>------------------------]  13%
20/74 [=======>--------------------]  27%
28/74 [==========>-----------------]  37%
29/74 [==========>-----------------]  39%
30/74 [===========>----------------]  40%
38/74 [==============>-------------]  51%
42/74 [===============>------------]  56%
49/74 [==================>---------]  66%
57/74 [=====================>------]  77%
62/74 [=======================>----]  83%
67/74 [=========================>--]  90%
72/74 [===========================>]  97%
73/74 [===========================>]  98%
74/74 [============================] 100%
7 package suggestions were added by new dependencies, use `composer suggest` to see details.
Package webmozart/path-util is abandoned, you should avoid using it. Use symfony/filesystem instead.
Generating autoload files
55 packages you are using are looking for funding.
Use the `composer fund` command to find out more!